Posts

Showing posts from May, 2013

Frogatto on X1000

Image
Today I wanted to take a look at the recently released AmigaOS4 game Frogatto on the AmigaOne X1000.


This game is Open Source and is available for free download on www.os4depot.net . It is another game port from HunoPPC, who has done many game ports to AmigaOS4...it is available for most other major platforms too and the original game website is here.

Like many of his game ports, Frogatto requires hardware acceleration which means you need to have a dual graphics card display setup on the X1000 using a Radeon 9250 card in order to run it. I have explained how to do this in a previous post here.

Assuming you have this setup on the X1000 you can try this game out! On extracted the archive, you get a folder containing launchers for different languages and Readme to explain more about the game. Since I was keen to get into it I launched the game!



From the main menu I chose the New Game option, which walks you through a very handy tutorial on how to play the game.

Essentially Frogatto is …

NetSpeedometer and NetDock on X1000

Image
Today I thought I would take a look at two programs for looking at the realtime network card performance on the X1000 - NetSpeedometer and NetDock.


Looking first at NetSpeedometer, it is available on os4depot.net and is written by Massimiliano Scarano.

After downloading the program, it is a simple matter to extract the contents of the archive to sys:utilities. The program is ready to run, no further configuration needed to get it going:

I read the NetSpeedometer.doc - no tooltypes or anything are needed to configure it. It does mention that if the network card device driver doesn't support the SANA-IIR4 extensions: the DNS address information can't be displayed, you will just see 'Unknown'. It also mention an AmiDock plugin could be done if enough people support the development by donating:
So let's move onto the program itself. The GUI shows three tabs - Status, Misc and Bandwidth:

As mentioned in the readme, the DNS addresses used are not shown in the Status ta…

Little trick for UADE custom module subsongs playback in TuneNet

Image
While testing HDAudio support in TuneNet, I stumbled across how to playing subsongs on custom Amiga modules when playing in TuneNet.


There have been a few updates to the UADE plugin for TuneNet since I originally looked at it (downloadable from os4depot.net). I have now found how to navigate through the subsongs in custom modules via the GUI - it just wasn't obvious!

For those who don't know what I am referring to with custom modules - in the beginning Amiga games were released with music written in a variety of different custom formats, before settling mainly on SoundTracker/Protracker (.MOD) and Octamed (.MED) for most games.

These original custom formats (DW, DL, TW, etc) contained not only the games music, but in some cases also the sound effects used in the games. As such, each individual game tune (eg. title screen, level 1 music, level 2 music, sound effects) had it's own subsong within the one custom module.

A similar technique was earlier used on the Commodore 64 …

HD Audio driver released for X1000

Image
It was with a lot of excitement that I keenly fired up my X1000 today to download the recently released HD Audio driver for the X1000.

So why the interest in the new X1000 audio driver? Well, the X1000 comes delivered with an internal Audio card on the motherboard supporting 7.1 channel audio, but until today it didn't work with the AmigaOS4.1 audio drivers. The reason for this is because the older AmigaOS4.1 drivers is for audio cards based on the old AC97 Audio card standard.

The Audio card built into the X1000 uses the newer HDAudio standard, which requires it's own driver, and this wasn't available at the time of the X1000's release.

Since A-Eon was obviously keen to get the X1000 out there asap, the decision was made to release it without HDAudio support and include a PCI audio card based on the AC97 standard that the AmigaOS4.1 audio drivers could use. The intention was to release the HDAudio driver "at a later time".

Well, that time is today! :-)

I ha…